HorizontalVariableListView
sephiroth74
862
Visit GitHub RepoList Views

Deprecated

This widget is now deprecated and it won't be updated anymore. Use RecyclerView instead

Horizontal Variable ListView

Horizontal ListView for Android. Based on the official ListView google code. The library includes also an ExpandableHListView, also based on the official ExpandableListView.
See the demo project for sample implementations

Usage (gradle)

Add this line to your dependency group:

compile 'it.sephiroth.android.library.horizontallistview:hlistview:1.2.2'

Features

It supports almost all the features of the ListView widget. There are minor differences in the attributes supported like "hlv_dividerWidth" instead of the default "dividerHeight".

This is the styleable used for the HListView class:

    <declare-styleable name="HListView">
        <attr name="android:entries" />
        <attr name="android:divider" />
        <attr name="hlv_dividerWidth" format="dimension" />
        <attr name="hlv_headerDividersEnabled" format="boolean" />
        <attr name="hlv_footerDividersEnabled" format="boolean" />
        <attr name="hlv_overScrollHeader" format="reference|color" />
        <attr name="hlv_overScrollFooter" format="reference|color" />
        
        <!-- 
        When "wrap_content" is used as value of the layout_height property.
        Pass the position, inside the adapter, of the view being used to measure the view
        or '-1' to use the default behavior ( default is -1 )
        -->
        <attr name="hlv_measureWithChild" format="integer" />
    </declare-styleable>
    

    <declare-styleable name="AbsHListView">
        <attr name="android:listSelector" />
        <attr name="android:smoothScrollbar" />
        <attr name="android:drawSelectorOnTop" />
        <attr name="android:cacheColorHint" />
        <attr name="android:scrollingCache" />
        <attr name="android:choiceMode" />
        
        <attr name="hlv_stackFromRight" format="boolean" />
        <attr name="hlv_transcriptMode">
            <enum name="disabled" value="0"/>
            <enum name="normal" value="1" />
            <enum name="alwaysScroll" value="2" />
        </attr>
        
    </declare-styleable>  

ChangeLog

  • 1.2.0 Added the ExpandableHListView

API Requirements

The minimum supported Android version is android 2.3 (API Level 9)

License

This software is distributed under Apache License 2.0: http://www.apache.org/licenses/LICENSE-2.0


Author Alessandro Crugnola

Become a better Android Developer
Millions of developers are learning at MindOrks

Online Training Program

Featured Blogs

Our Team

MindOrks is Certainly one of the best online blog to stay on top of all the Android development news, coding and design patterns. Finally a blog I can count on to keep myself updated with latest and greatest things happening in Android world.

Vipul Shah
Android Developer
Microsoft

Become Pro in Android by watching videos

OUR LEARNERS WORK AT